IPB

Здравствуйте, гость ( Вход | Регистрация )

-->
 
Ответить в эту темуОткрыть новую тему
> 2 wan 2 lan, каждая lan в свой wan
bdann
сообщение 20.5.2014, 22:34
Сообщение #1


Новичок
*

Группа: Пользователи
Сообщений: 2
Регистрация: 20.5.2014
Пользователь №: 6 401



Здравствуйте!

Помогите, пожалуйста, никак не пойму в чем ошибка..

надо чтобы lan1 выходила через шлюз1, а lan2(телефония) через шлюз 2.

в lan1 смотрит dhcp и выдает адреса из пула для локалки.

при данном конфиге на микротике есть инет, имена резолвит.

клиенты пингуют внешний шлюз, но дальше не идёт, dns имена с клиентов не резолвятся.




Код

/interface ethernet
set [ find default-name=ether1 ] name=ether1-gateway
set [ find default-name=ether2 ] name=ether2-gateway
set [ find default-name=ether6 ] name=ether6-master-local
set [ find default-name=ether7 ] master-port=ether6-master-local name=ether7-slave-local



/ip pool
add name=pool1 ranges=192.168.0.30-192.168.0.100
/ip dhcp-server
add address-pool=pool1 authoritative=yes disabled=no interface=bridge-local name=default

/ip dhcp-server network
add address=192.168.0.0/24 comment=local dns-server=8.8.8.8,xx.xx.91.2 gateway=192.168.0.1



/interface bridge port
add bridge=bridge-local interface=ether3
add bridge=bridge-local interface=ether4
add bridge=bridge-local interface=ether5
add bridge=bridge-local interface=ether6-master-local



/ip address
add address=xx.xx.91.50/30 interface=ether1-gateway network=xx.xx.91.48
add address=172.0.11.235/24 interface=ether2-gateway network=172.0.11.0
add address=192.168.0.1/24 interface=bridge-local network=192.168.0.0
add address=192.168.1.1/24 interface=bridge-local network=192.168.1.0
/ip dhcp-server network
add address=192.168.0.0/24 comment=local dns-server=8.8.8.8,xx.xx.91.2 \
    gateway=192.168.0.1



/ip dns
set allow-remote-requests=yes servers=xx.xx.91.2,xx.xx.81.2
/ip dns static
add address=xx.xx.91.2 name=dns1
add address=xx.xx.81.2 name=dns2



/ip firewall mangle
add action=mark-routing chain=prerouting in-interface=bridge-local new-routing-mark=wan1_mark passthrough=no src-address=192.168.0.0/24
add action=mark-routing chain=prerouting in-interface=bridge-local new-routing-mark=ats_mark passthrough=no src-address=192.168.1.0/24
/ip firewall nat
add action=netmap chain=dstnat comment="Phone Station" dst-port=12000-12500 in-interface=ether2-gateway protocol=tcp to-addresses=192.168.101.202
add action=netmap chain=dstnat comment="Phone Station" dst-port=16000-16500 in-interface=ether2-gateway protocol=tcp to-addresses=192.168.101.202
add action=netmap chain=dstnat comment="Phone Station" dst-port=35060 in-interface=ether2-gateway protocol=tcp to-addresses=192.168.101.201
add action=netmap chain=dstnat comment="Phone Station" dst-port=5060 in-interface=ether2-gateway protocol=tcp to-addresses=192.168.101.201
add action=masquerade chain=srcnat out-interface=ether1-gateway
add action=masquerade chain=srcnat out-interface=ether2-gateway



/ip route
add distance=1 gateway=xx.xx.91.49 routing-mark=wan1_mark
add distance=1 gateway=172.0.11.1 routing-mark=ats_mark
add distance=1 gateway=xx.xx.91.49
/ip route rule
add interface=ether1-gateway routing-mark=wan1_mark src-address=192.168.0.0/24 table=wan1_mark
add interface=ether2-gateway routing-mark=ats_mark src-address=192.168.1.0/24 table=ats_mark
Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения
Vasia
сообщение 22.5.2014, 0:32
Сообщение #2


Активный участник
***

Группа: Пользователи
Сообщений: 295
Регистрация: 8.4.2011
Пользователь №: 1 154



add action=masquerade chain=srcnat out-interface=ether1-gateway
add action=masquerade chain=srcnat out-interface=ether2-gateway
Вот тут у вас ошибка
Надо убрать маскарад интерфейса
Например так
add action=masquerade chain=srcnat

Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения
bdann
сообщение 22.5.2014, 5:49
Сообщение #3


Новичок
*

Группа: Пользователи
Сообщений: 2
Регистрация: 20.5.2014
Пользователь №: 6 401



Цитата(Vasia @ 22.5.2014, 0:32) *

add action=masquerade chain=srcnat out-interface=ether1-gateway
add action=masquerade chain=srcnat out-interface=ether2-gateway
Вот тут у вас ошибка
Надо убрать маскарад интерфейса
Например так
add action=masquerade chain=srcnat

Код
/ip firewall nat
add disabled=no action=masquerade chain=srcnat src-address=192.168.0.0/24
add disabled=no action=masquerade chain=srcnat src-address=192.168.1.0/24

так не работает тоже
Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения
Vasia
сообщение 22.5.2014, 10:52
Сообщение #4


Активный участник
***

Группа: Пользователи
Сообщений: 295
Регистрация: 8.4.2011
Пользователь №: 1 154



Код

/ip firewall nat
add action=netmap chain=dstnat comment="Phone Station" dst-port=12000-12500 in-interface=ether2-gateway protocol=tcp to-addresses=192.168.101.202
add action=netmap chain=dstnat comment="Phone Station" dst-port=16000-16500 in-interface=ether2-gateway protocol=tcp to-addresses=192.168.101.202
add action=netmap chain=dstnat comment="Phone Station" dst-port=35060 in-interface=ether2-gateway protocol=tcp to-addresses=192.168.101.201
add action=netmap chain=dstnat comment="Phone Station" dst-port=5060 in-interface=ether2-gateway protocol=tcp to-addresses=192.168.101.201

у вас адресов 192.168.101.0/24 нет
В dns надо поставить галочку allow remote request
Dhcp сервер должен выдавать клиентам шлюз микротик и днс микротик, проверьте
Возможно во всем виноват mangle, в целях проверки отключите его и добавьте маршрут без маркированных пакетов
add distance=1 gateway=xx.xx.91.49
Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения
« Предыдущая тема · Фаервол · Следующая тема »
 

Ответить в эту темуОткрыть новую тему
2 чел. читают эту тему (гостей: 2, скрытых пользователей: 0)
Пользователей: 0

 



Текстовая версия Сейчас: 17.6.2019, 2:00