IPB

Здравствуйте, гость ( Вход | Регистрация )

-->
 
Ответить в эту темуОткрыть новую тему
> 2 sip ТА за nat-ом и оба к 2 м серверам один сервер внутри VLAN
Evgeni K
сообщение 31.3.2015, 8:43
Сообщение #1


Новичок
*

Группа: Пользователи
Сообщений: 3
Регистрация: 31.3.2015
Пользователь №: 6 535



2 sip ТА за nat-ом и оба к 2 м серверам один сервер внутри VLAN
помогите голову сломал уже.
2 номера sip (2 ip телефона гигасет 510) надо подключить к 2 м разным астериксам, один провайдера находится внутри vlan.
пока вижу 2 варианта и оба пока без решения.
Вводные данные: локальная сеть 192.168.88.0/24 шлюз 192.168.88.1 eth2
Интернет и VLAN 3000 eth1
Канал до офиса и то что нас интересует сервер астерикса-2 172.16.1.1
Маршрутизация между сетями 192.168.88.0/24 и 172.16.1.0.16 есть.
Sip телефон 192.168.88.24 свободно работает с астериксом2 172.16.1.1
Внутри провайдеского VLAN3000 есть астерикск 1 88.0.0.1
Провайдер дал 2 ip адреса для телефонов 10.10.10.23 и 10.10.10.24 шлюз 10.10.10.1
1 вариант
Eth1 -VLAN3000 (VLAN1)
Бридж VLAN1 VLAN2
Eth2 VLAN3000 (VLAN2)
Телефон с адресом 10.10.10.23 шлюз 10.10.10.1 И!!!! VLAN3000
Аналогично с ТА 2
Но теперь вот это все надо дополнительно подключить к серверу астерикс2 172.16.1.1
Для создания маршрута нужен интерфейс с ип адресом в нашем случае с 2 мя адресами (2 телефона)
На VLAN ip адрес назначить нельзя - потомучто мастером у него является бридж – все больше идей нет .. можно попытатся промарикровать пакеты и их маршрутизировать но если нет маршрута из влановской сети во вне ее то и маркировать нечего.
2 вариант
Оба телефона в сети 192.168.88.0/24 и с сервером астерикс2 соединяются отлично.
Теперь надо придумать как из маршрутизировать в сеть провайдера 10.10.10.0 при том что надо назначить 2 адреса 10.10.10.23 и 24 внутри VLAN3000 ???? на интрфейс можно вроде назначить один адрес. Если будет входящий звонок по 2 му телефону то сервер1 не будет знать куда ему соединятся …


Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения
Evgeni K
сообщение 1.4.2015, 12:54
Сообщение #2


Новичок
*

Группа: Пользователи
Сообщений: 3
Регистрация: 31.3.2015
Пользователь №: 6 535



тема закрыта .. спасибо за помошь Константин (скайп kizimka4) помог
вообшем для натсройки нам потребовалось на порт 1 провайдера зацепить влан с тегом на него еше прицепить ип адресс - один из тех что провайдер дал.
/interface vlan
add interface=ether1-gateway l2mtu=1596 name=vlan3624 vlan-id=3624
add address=10.227.31.24/24 interface=vlan3624 network=10.227.31.0
нат на сеть до шлюза в сети влан
нат до адресса сип сервера внутри влан
нат на свой астерикс он в локальной сети но не в сети тика.. (так получилось до этих изменений работало и без ната только с помошью маршрута
вот
add action=masquerade chain=srcnat comment="тунель до офиса где все в том числе сип сервер" dst-address=\
172.25.0.0/16 out-interface=тунель до офиса где все в том числе сип сервер
add action=masquerade chain=srcnat comment="voip provider" dst-address=\
85.12.253.0/24 out-interface=vlan3624
add action=masquerade chain=srcnat comment="voip provider" dst-address=\
10.227.31.0/24 out-interface=vlan3624
add action=masquerade chain=srcnat comment=internet dst-address=\
!10.227.31.0/24 out-interface=ether1-gateway
как видим нижнее правило натит все остальное уже в мир
телефоны находятся в локальной сети 192.168.88.0
всем спасибо!
Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения
« Предыдущая тема · Фаервол · Следующая тема »
 

Ответить в эту темуОткрыть новую тему
2 чел. читают эту тему (гостей: 2, скрытых пользователей: 0)
Пользователей: 0

 



Текстовая версия Сейчас: 18.7.2019, 4:01